Dubbele content in Elementor? Gebruik een template!

Probleem: Afgelopen week was ik bezig met het ontwerpen van een nieuwe Elementor website op basis van het Hello Elementor thema. Op een van de pagina’s had ik de Post Widget toegevoegd om 3 blog berichten te tonen. Hierdoor kunnen bezoekers gemakkelijk door klikken naar nieuwe content. Een paar pagina’s later heb ik die Post Widget gekopieerd naar een nieuwe pagina waar ik ook 3

Lees meer

Hello Elementor child theme style.css inladen op de juiste manier

Maak je gebruik van het Hello Elementor thema? Dan maak je vast ook gebruik van een child theme. In dit child theme plaats je jouw eigen PHP functies en CSS aanpassingen die niet mogelijk zijn in Hello Elementor. Het Hello Elementor thema is eigenlijk een leeg thema zonder voor gedefinieerde templates. Handig als je zelf jouw gehele website met de Elementor plugin wil maken. Wil

Lees meer

Standaard WordPress thema’s installeren blokkeren via PHP

Probleem: Als je een WordPress installatie uitvoert krijg je er standaard de Hello Dolly en Akismet plugin erbij. Maar ook worden de standaard TwentyTen, TwentyNineteen en TwentyTwenty thema’s geïnstalleerd. Deze plugins en thema’s worden door WordPress ontwikkeld. Ik gebruik ze nooit. Na het installeren van WordPress installeer ik een eigen thema en verwijder ik de standaard WordPress thema’s. Maar eens in de zoveel tijd komt

Lees meer

WordPress 5.6 vervangt jQuery 1.12 met jQuery 3.5.1

Al jaren maakt WordPress gebruik van de jQuery bibliotheek. Dit is een verzameling van Javascript functies waardoor ontwikkelaars met minder code meer kunnen bereiken. Zo hoeven ontwikkelaars zelf geen code te schrijven die de waarde uit een formulierveld haalt of elementen in een website laat bewegen. Superhandig en heel krachtig. WordPress maakt er zelf ook veelvuldig gebruik van. WordPress 5.5 maakt op dit moment gebruik

Lees meer

Standaard kleuren / kleurcodes in Elementor instellen

Probleem: Je hebt van jouw opdrachtgever een aantal kleurcodes gekregen zodat de nieuwe website hetzelfde oogt als de bestaande huisstijl. Op die manier weet jij zeker dat jij de juiste kleur rood, geel of blauw gebruikt. Voor de nieuwe website maak je gebruik van WordPress en Elementor om pagina’s snel vorm te kunnen geven. In de elementen (widgets) van Elementor kan je telkens de kleurcodes

Lees meer

Hoe maak je in Jetpack Publicize het vak Aangepast bericht: groter?

De blogberichten die ik schrijf laat ik automatisch door Jetpack Publicize op mijn Twitter pagina plaatsen. Maar het vak voor het “Aangepast bericht” is altijd maar 2 regels hoog. Je kan dit wel via de rechter onderhoek groter maken, maar dit moet je elke keer doen. Ik vind het handig om standaard de volledige tekst te zien. Het leek mij het makkelijkste om hiervoor met

Lees meer

Elementor paginering werkt niet en toont “Pagina niet gevonden”

Probleem: Afgelopen week had ik voor een nieuwe WordPress website met Elementor een archief template aangemaakt. Het archief wordt door WordPress gebruikt om een overzicht van berichten te tonen. De pagina’s die getoond worden als je klikt op een categorie of tag zijn ook archiefpagina’s. Het ontwerpen van de pagina was binnen een uur gebeurt, alleen liep ik vast op de paginering. Als test had

Lees meer

Phlox sidebar is veel te hoog en zorgt voor te veel witruimte

Probleem: Het viel me sinds de overstap naar Elementor op dat de rechter sidebar op mijn homepage veel langer was dan de content in het middengedeelte. Met als resultaat een groot wit vlak in het primaire content gedeelte wat lelijk is. Uit onderzoek bleek dat de sidebar met de classes “aux-sidebar aux-sidebar-primary” een inline height waarde meekrijgt. Dit wordt niet door CSS ingesteld maar door

Lees meer

Phlox TypeError: DependencyManager is not a constructor

Probleem: Ik wilde wat wijzigingen doorvoeren in de widgets van mijn website maar dat lukte niet. Ik kon de widgets niet meer openen.  Als ik de inspector van mijn browser open door op F12 te klikken wordt de onderstaande foutmelding getoond. TypeError: DependencyManager is not a constructorscripts.js:1977:27 auxInitWidgetDependencies …/wp-content/themes/phlox/auxin/js/scripts.js?ver=2.5.13:1977 …/wp-content/themes/phlox/auxin/js/scripts.js?ver=2.5.13:1947 jQuery 2 …/wp-content/themes/phlox/auxin/js/scripts.js?ver=2.5.13:1946 jQuery 4 Het lijkt erop dat het te maken heeft met het

Lees meer
Winkelmandje